Templete message não funcionando

Boa tarde pessoal, eu fiz um template message para abrir um webview para o usuário digitar a senha e coloquei ele no meu fluxo no whatsapp porém não está aparecendo, alguém poderia me ajudar! Segue o conteúdo dinamico:

Captura de Tela 2022-09-30 às 15.57.39

{
        "type": "template",
        "template": {
            "namespace": "67d9f6d3_e7fc_400c_9773_d2b4978f2736",
            "name": "digitasenha",
            "language": {
                "code": "pt_BR",
                "policy": "deterministic"
            },
            "components": [
                {
                    "type":"button",
                    "sub_type": "url",
                    "index": 0,
                    "parameters": [
                        {
                            "type": "text",
                            "text": "{{url}}"
                        }
                    ]
                }
            ]
        }
    }

Olá @Wellington_de_Brito!

Pode nos compartilhar um print, se possível, do modelo que foi aprovado e que deseja adicionar no fluxo do chatbot?

@Romulo_Rafael segue o print do modelo e o script de continuação do link.

Alguma solução para o meu problema?

Bom dia, alguém pode me ajudar a resolver esse problema acima?

@GabrielPetrone, @Romulo_Rafael, @Rafael_Figueiredo poderia me ajudar aqui? Eu estou desde sexta feira com essa solicitação e ninguém me responde!!

@Wellington_de_Brito tudo bem ?

O problema é que esse body funciona para o envio via api e para o conteúdo dinâmico é um pouco diferente a escrita. Vou fazer uns testes aqui e te falo assim que der.

Beleza! Estou aguardando! Eu estava fazendo assim antes mas agora não está funcionando mais

@Wellington_de_Brito fiz os teste aqui e o que está dando erro é o nome do template, está correto ?

Acredito que sim!!


Captura de Tela 2022-10-04 às 13.13.25

@Wellington_de_Brito fiz o novo teste com esse e está funcionando corretamente :

{
        "type": "template",
        "template": {
            "namespace": "67d9f6d3_e7fc_400c_9773_d2b4978f2736",
            "name": "digitar_senha",
            "language": {
                "code": "pt_BR",
                "policy": "deterministic"
            },
            "components": [
                {
                    "type":"button",
                    "sub_type": "url",
                    "index": 0,
                    "parameters": [
                        {
                            "type": "text",
                            "text": "{{url}}"
                        }
                    ]
                }
            ]
        }
    }

Aqui para mim não aparece no whatsapp!! O que pode estar acontecendo?

@Wellington_de_Brito por esse motivo :


obs: cortei o print para proteger os dados.

Sei que não é muito claro, mas o link está ficando grand e com espaço ente a date e o tempo
repare o final do print

entendi! Vou ver aqui o que pode ser feito e já retorno!

@Wellington_de_Brito uma dica que eu dou é gera esse link manda para um encurtador de url via requisição http pega o retorno e coloca no template.

Mas como eu enviaria esse link com as variaveis que o usuário está escolhendo durante o fluxo?

@Wellington_de_Brito da mesma forma que você faz para coloca a url no template. passa ela na requisição com chaves duplas

Não entendi! Desculpa

Exemplo do teste feito no postman :


ai no Blip você troca o valor para fica assim :
image

1 curtida

Resolvido!

1 curtida