Resposta Assistente de Conteúdo não está funcionando

Bom dia, pessoal,

Meu bot está conectado junto ao DialogFlow e mesmo apesar do match em uma intenção dar 100%, a entidade estar cadastrada tanto no BLiP quanto no DialogFlow e ainda ter uma entrada no Assistente de Conteúdo, a minha Condição de Saída não ativa

E aí sou levado ao bloco de Entrada Inesperada do meu bot.

O que pode estar acontecendo?

Print do meu Assistente de Conteúdo do que eu estou tentando:

Eu estou com o mesmo problema. Porém observei que a variável que você está testando está como input.contentAssistantname (sem um ponto entre o Assistant e o name)… pela documentaçao o nome da variável é input.contentAssistant.name (com o ponto)

Coloque o ponto e faça um teste. Porém no meu caso eu estou com o nome input.contentAssistant.name e mesmo assim não estou conseguindo fazer funcionar também.

Ei Marcelo, eu mudei a condição para
“Se intenção identificada existe -> Resposta”
e deu tudo certo!
Corrigi aqui o erro que você me apontou e deu certo também, tenta testar o modelo e Publicar ele e tente de novo!

No meu caso ainda não consegui fazer funcionar.

Me passa a impressão que as variáveis abaixo simplesmente não estão sendo carregadas com conteúdo

  • input.contentAssistant.name
  • input.contentAssistant.result

Nos testes, a intenção e as entidades foram reconhecidas corretamente.

Porém ele não entra nessa condição de saída

image

Até coloquei as variáveis para serem exibidas para ver se identificaria algo e realmente apenas pisca no momento que elas seriam exibidas, como se realmente não houvesse valor dentro delas…

Se alguém tiver alguma dica me ajuda… não estou sabendo mais o que verificar

Mais uma informação…

As variáveis nem aparecem como sugestão ao informar o nome dela, como ocorre com as demais.

As variáveis input.contentAssistant.id, input.contentAssistant.name, input.contentAssistant.result não são exibidas…

image

Será que não está ai algum erro?