[Resolvido] Redirecionamento a um serviço não funciona

Olá

Estou tentando criar um bot que direciona para outros bots secundários dependendo do caso.
O meu problema é que o direcionamento não funciona, não sei exatamente o que fiz de errado no fluxo, alguém poderia me dar uma mão? (Não consigo adicionar imagens pois novos usuários tem limite, se não postaria o fluxo…)

O bot principal é acessado normalmente, e consigo chegar até o bloco de redirecionamento, porém para ai. Tentei reescrever o serviço com outro nome, refiz o fluxo, mas nada adianta…

Outra questão que acho estranha é o fato de nao ter um botao de adicionar acao de saida, os dois sao de entrada, deveria ser assim? Tem alguma relação com meu problema?

Se alguém souber a resposta ou tiver o mesmo problema, agradeço a ajuda!

Estou tendo o mesmo problema. Tenho um bloco apenas para redirecionamento para outro bot, mas ele não reconhece a ação de saída e vai direto para a saída padrão, caindo na exceção sempre.

Olá @guilherme.grando e @gwChatbot,

Preparei dois tutoriais que ensinam passo a passo como utilizar um bot router e ação de redirecionamento de serviços. Para acessá-los clique nos links abaixo:

Sobre a dúvida de ações de entrada e ações de saída, explico qual a diferença entre elas no artigo abaixo:

Resumindo:

Uma das funções de um bloco (o estado) é executar ações de entrada e saída. Uma ação representa uma tarefa que deve ser executada antes do envio dos conteúdos de um bloco (ação de entrada), ou uma tarefa que deve ser executada após o envio dos conteúdos e antes da transição entre o estado atual e o próximo (ação de saída).