[Resolvido] Pagseguro não funciona


#1

A documentação é fraca, não temos exemplos e ao executar o POST não retorna nada!
Pra falar a verdade, nada chega no Pagseguro, pois os logs estão vazios!


#2

Olá Jhoni,

Dê uma olhada aqui:
https://docs.blip.ai/#payment-invoice

Basicamente, para utilizar esta integração, vc precisa mandar um invoice para [identificador_do_cliente_escapado]@pagseguro.gw.msging.net. Obviamente é preciso configurá-la primeiramente no portal do BLiP.

Quando o houverem mudanças no status do pagamento, vc receberá uma mensagem do tipo application/vnd.lime.payment-receipt+json. Veja mais sobre este tipo aqui:

https://docs.blip.ai/#payment-receipt


#3

Eu usei o pouco que há na documentação, mas o status de retorno é 202 e nada mais.
Nada chega no PagSeguro.
Não sabemos visualmente como tudo isso funciona.
Não temos exemplos.


#4

Gesus, o que vem a ser isso?


#5

Bom, tem duas documentações sobre Invoices, diferentes uma da outra.
Numa das documentações tem http://www.w3schools.com/tags/ref_urlencode.asp como referência e não o escape().
Independente disso, não explica o que é pra fazer com isso.
Suspeito que deva ser com o contact.identity, mas nem isso resolveu.


#6

Encontrei isso no developers.facebook.com

As of July 27, 2017 , the implementation and usage of webview payments from Messenger Platform versions v1.2 - v2.0 are deprecated. Support for the deprecated usage will continue until February 1, 2018 .

All integrations for payments in the Messenger webview, using the Messenger Extensions SDK should migrate to the usage described in this document.

Como está isso?