[Resolvido] Integração Google Sheet e plataforma BLiP

Olá a todos,

Gostaria de saber como faço para integrar a plataforma BLiP com o Google Sheet.

O objetivo é validar com base na entrada do usuário via chatbot o valor digitado consultando uma planilha no Google Sheet, ou seja, se o valor existir eu gostaria de trazer a linha correspondente onde foi encontrado a entrada que o usuário digitou.

Já foi criada a planilha no google sheet, gerada a secret key, client id, Code,etc… A autenticação via plataforma BLiP com o Google Sheet está funcionando bem. O segundo passo é usar as funções que o Google Sheet oferece para percorrer a planilha, dar match no valor encontrado e retornar o resultado da linha…

Vocês poderiam me ajudar com isso por favor? É extremamente urgente…

Vlw.

Eu posso te ajudar, tem whatsapp? ou Skype.
Vamos fazer uma chamada via skype e eu te ensino.
igor.junio2

Sim, claro, segue meu WhatsApp (11) 9 96188758 e meu Skype: lucmoraes16

1 Curtida

Fala @Lucas_Moraes se tiver dado certo, comenta ai abaixo.

Vou gravar os videos melhores e postar novamente no yt.

1 Curtida

Fala @igor_junio_dos_santo, deu tudo certo. Como referência usei seu video para criar a api e depois executei um requisição no método PUT na url do googleapi passando como parâmetro o ID da minha planilha. e passei no corpo a formula excel abaixo:

{
“range”: “procv!A1”,
“values”: [["{{cpfCnpj}}", “=SEERRO(ÍNDICE(Customers!C:C;CORRESP(A1;Customers!B:B;0));0)”]]
}

Para tratar os campos que eu queria na variavel de retorno, usei o script abaixo:

     function run(inputVariable1) {
            var response = JSON.parse(inputVariable1);
            var enterprises = response.enterprises[0];
            var cell = enterprises.cell;
            return cell.name; //Return value will be saved as "Return value variable" field name
        }

Valeu pela ajuda.
Lucas Moraes

2 Curtidas