[Resolvido] ES6+ nos scripts do Blip

Boa tarde,

estava tentando executar um script como ação de saída de um bloco e o debugger apontou os erros de ‘unexpected token’ e ‘fetch is not defined’. Gostaria de confirmar se os scripts do Blip realmente não suportam ES6+ e fetch api. Senão seria uma boa ideia adicionar o suporte.

Esse era o código:

function run(inputUsuario) {
            let smallTalksResponse = fetch(`https://az-infobots.take.net/smalltalks/api/analysis?text=${inputUsuario}&checkDate=false&infoLevel=1`)
                    .then(response => response.json());
            return smallTalksResponse;
        }

Olá @Gabriel_Silva_Branda,

Existe um tópico no fórum com este mesmo conteúdo, segue resposta :tipping_hand_man:t5:

1 Curtida