[Resolvido] Erro ao treinar o bot Dialogflow

Boa tarde,

Eu estou tendo problemas com o treinamento do bot com o dialogflow, já adicionei as intenções e chequei aqui no forum outros problemas de outros usuários, nenhum deles funcionou e por causa disso estou treinando direto no dialogflow, porém não sei ao certo se o bot está agindo como deveria.
image

Bom dia @REIS0

Você ainda não consegue treinar o DialogFlow pelo Builder? Você poderia, por favor, enviar um printscreen da área de DevTools do seu navegador (F12 no Chrome e no Firefox) como na imagem abaixo?

Pelo que percebi estou conseguindo treinar o bot usando o IBM Watson, porém quando conecto novamente ao Dialogflow o erro volta a acontecer, então é um problema do Dialogflow em si pelo jeito.

Aqui o print do devtools

Tenta desconectar o Watson e treinar novamente o DialogFlow, por favor, pra gente fazer um teste.

Mesmo fazendo isso continua o erro, creio que possa ser algum erro do próprio servidor do Dialogflow ou alguma configuração dentro dele, tanto que eu consigo usar tambem o LUIS com o Watson sem problemas.

Por favor, confirme se você configurou o provedor corretamente, de acordo com nosso tutorial, especialmente na seção 6 - B) Na opção papel do projeto selecione Administrador da Dialogflow API:

Como configurar o DialogFlow como um provedor de Inteligência Artificial

1 Curtida

Funcionou, recriei o agente e a conta de serviço na google cloud assim reconfigurando o provedor, agora está treinando sem problemas, obrigado pela dica.

Adicionando que por algum motivo as intenções chegam ao Dialogflow mas a entidades não.

@REIS0 que ótimo! :blush:

Essa questão das entidades é algo esperado. O BLiP trata elas por si só. Caso você queira mandar as entidades para o DialogFlow, você vai precisar fazer uma mudança nas configurações do BLiP. Dá uma olhadinha neste tópico, talvez possa ser útil: [Resolvido] Problemas BLiP X Dialogflow