[Resolvido] Erro ao enviar mensagem após algum tempo de inatividade

Estou trabalhando no desenvolvimento de uma integração de uma plataforma de CRM com a plataforma de vocês, e estou tendo o seguinte comportamento:

Após um determinado tempo de inatividade, onde não há troca de mensagens entre as duas pontas (cliente e atendente), o atendente, ao tentar enviar uma mensagem, recebe um evento de falha com a seguinte informação.

Only the current active service can redirect to another service (Code 101)

Outra coisa que percebi, é que quando isto começa a ocorrer, não recebo mais as mensagens que o cliente envia, ou seja, o cliente envia uma mensagem pelo aplicativo, mas na SDK o evento de nova mensagem recebida não é disparado, e quando eu envio uma segunda mensagem, o bot entra em ação novamente no inicio do fluxo configurado.

Somente para contextualizar, a integração entra em ação quando a inteligencia do bot não consegue dar continuidade com o atendimento, transferindo então a conversa para um humano, a partir dai a troca de mensagens é feita utilizando a interface do CRM.

Para desenvolvimento estou utilizando a SDK C# de vocês, e o Telegram para realizar os testes.

Eu não sei se isto está relacionado justamente com este tempo de inatividade, mas é o único padrão que encontrei até o momento, vocês conseguem me ajudar com este item?

2 Curtidas

Olá, @Renan_Magalhaes_Sara.

Pela sua descrição e pela mensagem de erro, você está utilizando um bot roteador, e direcionando o atendimento humano para um bot com SDK, certo?
Veja que na configuração dos serviços do roteador existe um tempo de “expiração do redirecionamento”, que é de 30 minutos conforme a imagem abaixo:

Se você deixou no padrão, como acima, após 30 minutos realmente acontecerá o que você descreveu.

Marque o checkbox Não redirecionar automaticamente para o principal para que esta expiração seja desabilitada. Quando o atendente encerrar o trabalho será preciso redirecionar via SDK para outro bot configurado no router, usando um Redirect.

1 Curtida

@andre Muito obrigado pela informação!

Por nada.
Se tiver resolvido seu problema, confirma aqui pra gente, por favor.

Consegui resolver alterando a configuração, obrigado!