[Resolvido] Bot não direciona mesmo com intenções corretamente identificadas pelo Dialogflow e blocos configurados

Meu bot está com os blocos configurados corretamente, e as intenções também corretamente carregadas no dialogflow. Tudo estava funcionando certinho, até que desde ontem o bot parou de direcionar conforme programado. Conferi no aprimoramento e ele está identificando as intenções corretamente, mas por alguma razão o bot não está aceitando ou direcionando. Usei o debug e ele simplesmente ta passando direto, como se não estivesse reconhecendo intenções.

Pode ser um problema temporário, mas como já estamos quase com 24h de duração eu achei melhor relatar.

O problema persiste… coloquei imagens pra exemplificar:

envia comprovante
O bot não encaminha minha entrada.


Mesmo com IA (Dialogflow) reconhecendo a intenção

config-builder
O direcionamento configurado no builder

confiabilidade
E a confiabilidade do bot ta em 50%. A intenção foi reconhecida mais de 75%.

Mas o principal: estava funcionando normalmente. Parou do nada. Houve alguma alteração na ferramenta?

Mais um update: descobri que o problema de compreensão ocorre somente quando a conversa se dá por meio do Blip Chat (consequentemente, também no ambiente de testes do Blip)… pelo whatsapp o bot compreende e direciona corretamente.

Caso suas intenções que o bot utiliza esteja no bot roteador. o mesmo não irá entender nos teste direto no bot.

1 Curtida

É um bot único, sem ramificações ou redirecionamento. Não existe um roteador.

E la no aprimoramento, a resposta aparece com mais de 50% de confiança ?

Eu ja tive este problema quando no meu bot estava com a opção de contexto roteador ativa, mas não é o seu caso.

1 Curtida

Sim, aparece com 76% de confiabilidade, conforme a imagem que mandei. Mas o que deixa tudo mais estranho é não funcionar somente pelo blip chat… pelo whatsapp ta tudo ok. E antes estava tudo funcionando corretamente. Não alterei nada no bot. Parou de funcionar de repente mesmo.

Olá @George_Oliveira,

O problema ainda ocorre?

Caso sim, se você for um cliente Business/Entreprise, por gentileza, abra um chamado com o seu suporte para que possam investigar o erro com mais proximidade :man_technologist:t5:

Se você é um usuário free, me informe aqui, por gentileza, que irei analisar o problema :grin:

Cliente Enterprise. Continua o problema. Vou abrir o chamado. Obrigado!

1 Curtida