Erro 400 (BadRequest). (81) Mensagem ativa 1 parâmetro

Boa tarde / Dia / Noite!

Estou tentando enviar uma mensagem ativa com apenas uma variável e não consigo, quando uso o mesmo .Json e adiciono a segunda variável a mensagem é enviada sem erro.

No console tenho a seguinte mensagem:
Event: failed
Reason:WhatsApp API response status code does not indicate success: 400 (BadRequest). (81)

O .Json utilizado é:

{
“id”: “{{$guid}}”,
“to”: “[email protected]”,
“type”: “application/json”,
“content”: {
“type”: “template”,
“template”: {
“name”: “mensagem_de_aviso_01_variavel”,
“language”: {
“code”: “pt_BR”,
“policy”: “deterministic”
},
“components”: [
{
“type”: “body”,
“parameters”: [
{
“type”: “text”,
“text”: “\nColaborador01 - Dias Sem Checkin: 2”
}
]
}
]
}
}
}

1 curtida

Bom dia @Multitecnica , seja bem vindo a nossa comunidade :smiley: !!!

Te aconselho a baixar nossa collection da Api(aqui) nas variables você coloca a key do router onde está localizado a notificação ativa, assim já facilita o authorizathion dos demais endpoints.

Logo apos vai em:

image

O seu json deve ficar da seguinte maneira:

Testei dessa maneira e recebi a Notificação Ativa perfeitamente !!! Talvez seja algum campo que você preencheu errado, ou passagem de parâmetro incorreto. Dê uma olhadinha e me fala se deu certo!

Obs: Vi que no json que você postou não possui o namespace. Esse id fica localizado no router onde está o notificação ativa. Basta ir em conteúdos > modelos de mensagem e clicar em qualquer notificação.

1 curtida

Bom dia Aline,
Primeiramente muito obrigado pelas suas pontuações, mas, acaba que a solução apenas remover o “\n” do inicio da variável enviada.

Muito obrigado!

1 curtida