[Em análise] Na frase do usuário Entidade acentuada não é reconhecida

O usuário ao digitar uma frase onde a entidade estiver acentuada, ela não é reconhecida.

Estou utilizando o Blip no modo router com mais de 30 sub-bots e DialogFlow.

1 Curtida

@FernandoSinesio

Qualquer entidade ou apenas para alguma específica?

Qualquer entidade acentuada!
Inclusive fiz um teste trocando o provedor do Dialogflow para o LUIS, inserindo um sinônimo diretamente nas entidades do LUIS e assim funcionou, porém, ao (RE)publicar no Blip, os sinônimos no LUIS somem de acordo com a regra de negócio do Blip: “Não precisamos de provedores de NLP para analisar entidades (fazemos isso por comodidade). O que realmente é identificado são os valores da entidade e os sinônimos.” (https://help.blip.ai/docs/ai/nlp/conceitos-basicos-nlp-e-ai/#entidade)

Vamos analisar, @FernandoSinesio

Assim que tiver um retorno, eu te aviso, ok?

1 Curtida

Estou com a mesma situação aqui, eu tinha um chatbot rodando a algum tempo e de repente parou de responder e no debug não gerava log algum, após um tempo identifiquei que o motivo de ter parado era que algumas entidades estavam cadastradas com acentos e cedilhas, sendo assim removi e funcionou normalmente.

Gostaria de saber se o cadastro de entidades agora no blip deve ser cadastrado sem caracteres especiais ou se isto é um caso atípico que precisa ser analisado?

Pessoal, resolvi testar pelo IBM Watson e funcionou normalmente. 100% Entidades sendo reconhecidas.
Para o Watson não faz diferença se as palavras estão acentuadas, ao treinar o modelo no Blip, as palavras “sobem” para o Watson sem os acentos.

1 Curtida

O problema agora é que a versão free só permite até 25 entidades.