Definir (Adicionar mais variáveis) ao contato em outros bot que estão ligados no Router

Fiz um teste aqui, com um Router, com dois bots, no primeiro Bot eu pego nome, telefone, quando passo para o outro bot, eu peço o nome da Casa do usuário, para adicionar ao contato e ao atender o usuário no Blip Desk, estas informações não aparecem (Durante o segundo bot também adiciono o Gênero Masculino):


image

  • O nome e telefone no primeiro bot adicionam normalmente;
  • O nome da casa que está no segundo bot não é adicionado.
  • Nem o gênero Masculio;
  • O Roteador de contexto está ativo nos dois.
    Bot 1:

Bot 2:

Isso é o esperado?

Bom dia meu amigo, pode me dizer definiu o contato com ação de saída. ou ação de entrada ?

Bom dia Pedro, defini como ação de saída, após o cliente informar o que foi solicitado.

Pode ser duas coisas, quando o contexto de roteador está ativado não se consegue atualizar as informações no Bot, para indentificar se é esse o problema a duas maneiras, chamando o bot por um número por um número que nunca chamou antes, ou olhando no contatos do router, mas veja se o fluxo está atualizando essas semana tive um problema com um fluxo que eu atualizava mas ele não subia as atualizações de fato

Fiz um novo teste e agora nos contatos do Bot Router apareceu:

.

Mas ainda no Desk, não tenho a informação das variáveis (nomeCasa e gênero) que foram adicionadas no Bot 2:

então é isso vai ter que atualizar manualmente, estou fazendo uma documentação que pode ajudar mas acho que o ideal é pedir ajuda para o suporte

1 curtida

de qualquer forma @Bruno @CommunityTeam @HerculesNakai vejam se conseguem ajudar ele

Para sua alegria, eu fiz uns testes agora e acho que achei a solução do teu problema

1 curtida

Opa, se puder contribuir.

to montando a documentação logo eu posto

3 curtidas

Opa, alguma outra solução além de atualizar manualmente? Estou passando por um problema semelhante, a ação de definir contato no sub-bot aparentemente não está atualizando os dados do contato no router.

1 curtida

como assim? não entendi, quando vc atualiza o sub bot, ele não atualiza o router?

Então, verifiquei e na verdade é um problema causado por mim, que agora vai ser meio complicado refatorar :man_facepalming:, basicamente o meu bot principal não está utilizando o contexto do router, mas o segundo bot está, ele atualiza o contato no router, mas acho que quando ele vem do bot principal para o sub-bot mesmo que o sub-bot esteja no contexto do router ele vem com os dados do Bot Principal.