Bug na Tela de Boas-Vindas

Experienciando o seguinte:

  1. Criei um bot e inseri a descrição “Fale Conosco” no campo “descrição” das “Configurações básicas”.
  2. Habilitei a “Tela de Boas-Vindas”.
  3. A descrição “Fale Conosco” apareceu abaixo do avatar.
  4. Retornei nas “Configurações básicas” e alterei a descrição para “bot4u”.
  5. Salvei, recebi a confirmação, e agora o campo “descrição” apresenta “bot4u”.
  6. Retornei na “Tela de Boas-Vindas” e a descrição “Fale Conosco” não foi alterada.

Tentativas de troubleshooting:

  1. Limpei o histórico do browser.

  2. Fiz login novamente.

  3. Acessei a “Tela de Boas-Vindas”.

  4. A descrição continua “Fale Conosco”.

  5. Desabilitei a “Tela de Boas-Vindas”.

  6. Habilitei a “Tela de Boas-Vindas”.

  7. A “descrição” continua “Fale Conosco”.

  8. Acessei as “Configurações Avançadas”.

  9. Editei “builder.hosting@msging.net”.

  10. Mudei o “identifier”:“FaleConosco5” para “identifier”:“bot4u5”

  11. Confirmei a alteração.

  12. Desabilitei a “Tela de Boas-Vindas”.

  13. Habilitei a “Tela de Boas-Vindas”.

  14. A “descrição” continua “Fale Conosco”.

Podem me ajudar?

Olá @Jose_Jacques_de_Oliv tudo bem com você?

A Descrição na tela de Configurações Básicas não deveria refletir em nada na tela de Boas-vindas, exceto pelo nome do bot e pelo avatar. Pelo que eu pude notar, o que você quer mudar é o nome do bot. Se mesmo assim o nome não estiver sendo alterado, pode ser um bug mesmo. Poderia verificar, por favor?

Aqui você alterou o ID do bot e não o nome dele. Muito cuidado ao fazer isso, pode comprometer todas as conexões do seu bot.

Obrigado @Bruno! Td bem por aqui! Espero que com vc tb esteja!

Vc está certo, eu confundi o Bot ID com descrição, mas testei novamente, desta vez mudando o nome do bot, e a Tela de Boas-Vindas continuou apresentando o nome anterior.

O mais interessante é que fiz isso tb com outros bots que eu já havia criado e o resultado foi que em alguns o problema aparece e em outros não.

Parece que o bot está aceitando a primeira troca de nome e apresentando na Tela de Boas-Vindas. A partir da segunda ou terceira troca de nome o bug aparece pra mim.

Que estranho, Jose. Você poderia me passar os IDs dos bots em que isso acontece? Vou levar o problema para a equipe responsável.