[Analyzing the problem] Error in Retrieving Data from Workplace Using Webhooks (Account Management API)


#1

Hi! So I am using this Account Management API (webhooks) from Facebook Workplace, so that I can retrieve a user’s data: https://developers.facebook.com/docs/workplace/account-management/api/

I can successfully retrieve it using Postman.

I copied the URL and the headers in BLiP, but I cannot retrieve the JSON response. Instead, this is what’s happening:

I displayed the response status and it says 200 meaning it was successful. However the response body is null. What could be the possible error of this? Please help because I’m stucked here for too long.

Here are the webhooks I enabled on my Workplace Integration:


#2

Hi @Francis_Earl_S_Fojas,

  1. Let’s double check if you are using the same name to access the variable.

What is the variable name that you used to get the request response?
What is the pattern that you are using to log the variable?

  1. Are you using the correct headers to make this request inside builder?

#3

Yes I do use the same variable.

Here’s when I retrieve it using HTTP Call:


Note: You can also view here that I used the same headers I put in Postman

Here’s when I accessed it:
image


#4

Hi @Francis_Earl_S_Fojas,

Have you checked your flow on Builder?
Can you check if there is any problem that?


#5

Hi Rafael! I checked it and there is no problem in the flow of the Builder, that is because I tried that Integromat will be the one to call the Facebook Workplace API, and then Integromat will pass that JSON to BLiP. It is successful.

But when BLiP directly calls this Workplace API, its response body becomes null :frowning:


#6

Great @Francis_Earl_S_Fojas,

I’ll check what can be wrong in our side.


#7

Thank you very much Rafael! I appreciate it very much. =)