Ajuda para Enviar requisição pelo Postman

Oi Gente, estou com uma pequena dúvida, chega até a ser besta.
Estou vendo um tutorial sobre
Como enviar notificações WhatsApp via API do BLiP

Estou com meu Whatsapp Business todo configurado e já em funcionamento.

Mas estou com problema na hora de enviar requisição pelo Postman, para poder buscando o identificador de um cliente.
Eu preencho o campo Body conforme vi no vídeo.

Quando envio a requisição, não retorna nada.
Não sei oque devo preencher a mais, poderiam me ajudar por gentileza??

Fala Fabrizio!
Cara você parece não estar usando o método correto, veja qual eu uso aqui:

Você baixou o Collection do Blip?
https://docs.blip.ai/#postman-collection

Esse método que citei ta aqui: https://docs.blip.ai/#whatsapp

Oi Gabriel, este print que você mandou, já é o envio da mensagem.
Meu problema esta antes disso kkk
Não estou conseguindo enviar a requisição para coletar o número de identificação que é enviado pelo whatsapp.

Vi o Collection do Blip que você mandou, mas na parte de colocar a variável Authorization você coloca o valor da Cabeçalho de autenticação (Authorization) nos dois campos ?

Bom dia, @Fabrizio_Queiroz_de, tudo bem?

O campo Authorization deve ser enviado nas Headers da requisição e não pela opção de Authorization do postman, aqui vai um exemplo:

E o seu body está correto, mas vale lembrar que o id enviado deve ser uma string unica gerada a cada requisição, pra isso você pode usar no postman a variavel {{$guid}} e seu body ficaria algo parecido com isso, por exemplo:

{
    "id": "{{$guid}}",
    "method": "get",
    "uri": "/ping"
}
1 Curtida

Nos outros parâmetros eu deixo assim ou tenho que configurar alguma coisa?

1 Curtida

Os Parâmetros pode deixar em branco, só rodar com os dados igual o Gabriel postou acima que já vai dar rock.

1 Curtida

Estou enviando a requisição desta forma e esta me retornando o erro 401.

Veja que o link que estou enviando no POST é igual ao que vocês mostraram nos print:

https://http.msging.net/commands
e o link que mostram no manual é diferente

POST https://http.msging.net/commands HTTP/1.1

Mas quando mando pelo link ( https://http.msging.net/commands HTTP/1.1 )
ele retorna 404.

Não sei oque posso estar fazendo de errado.

Aparentemente o problema está no seu código de Authorization, na aba Headers.

Você precisa preencher com a Chave de API do seu Bot, dá uma olhada aqui:

Consegui resolver, muito obrigado!
Estava colocando a key errada, agora esta tudo OK
Valeu!

2 Curtidas

Este tópico foi fechado automaticamente 7 dias depois da úlima resposta. Novas respostas não são mais permitidas.